DOSBoxWiki talk:Community Portal

From DOSBoxWiki
Revision as of 09:03, 4 August 2010 by Rhwilliams 007 (talk | contribs)
Jump to navigationJump to search

Same issue (different game) as the following. No way to get a backslash (\) in DOSBox running on an new HP with Vista. Anyone figured this one out yet? [I hate Vista!]

No "\" capable, therefore can't mount anything

I just got an old game that i love 2 play called "full throttle" only it wont work with windows vista for some reason. So i downloaded DOSBOX and it looked like i wuz well on my way to playing but i couldnt change the drive to my cd drive because i couldnt type ":" or "\" for some reason....if anyone has any knoledge that will help me it would be much appreciated...thank you

I get the same thing, I cannot use the \ key, how can I fix this?

OpenGL Non Bilinear (Filtering)

output = surface | overlay | opengl | openglnb | ddraw
What to use for output.
Default is surface.
(since 0.??)

Your search - openglnb - did not match any documents.

Don't blame on Wikipedia. They talk about bilinear filtering. Blame on...

May Help

My keyboard (Microsoft) has a key "Ç". To see ":" I type shift + Ç. If it seems ok, try shift + another key for "\". I hope it helps you. Dixon - Brazil - Bahia.

I need a help too: I'm trying to run the game Blackthorne. I mount c:\DOSGames and all is ok, but when I try to run the .exe file, nothing happen and the commands crashes. A friend told me that this game needs EMS memory and is necessary to add a line to config sys file, like that: himem.sys:device=c\DOS\EMM386.exe RAM. I don't know if it is right or no. If true, how can I edit the config.sys file, or what to do to run this game? Thank you.


I had the same issue with my original CD vesion of Blackthorne, but I tried a copy from,

And it worked without issue!

May have messed up Keymapper

Ctrl-F1 no longer brings up Keymapper. I was trying to get the "\" and perhaps I messed up. How can I get keymapper back? (Am using Windows 7 and somehow in my efforts to get a c:\\ I succeeded one time and brought up Q&A, which is the old DOS program I want to work. So there must be a way .. Thanks.

You can try running DOSBOX with the command line -startmapper (it will look like dosbox -startmapper)

Loading Games Using Batch Files

Possible Solution.....

You are typing a slash '\' now, so you must be able to use a slash in notepad.

Try using the dosbox.conf and batch files to load games.

Here is a neat trick I figured out for running Dosbox games fast ans easy.
First edit the dosbox.conf file, under [autoexec] to mount a new drive letter and folder you will not use.

# Lines in this section will be run at startup.
mount Y C:\gamelist\


The code above if entered into Dosbox.conf, when you open Dosbox, it will mount, load, and go to this folder, displaying the files with-in.

Now just create batch files with the commands normally used to load doxbox games, place them in the gamelist folder (C:/gamelist)


My Batch File Example- Type in notepad, save as FILENAME.bat

mount c c:\harvest
mount d d:\ -t cdrom


I saved this batch file as harvest.bat. Now when I open Dosbox, it automatically opens the gamelist folder, and displays the files, (only harvest.bat now).

Now you only have to type harvest.bat (or any other game.bat you have), to mount and play your games.

Keyboards and Dosbox.config

You should probably check out your dosbox.config file and see if the keyboard settings are correct.
Also, Dosbox has EMS memory enabled by default, as you can see in the dosbox.conf file.

Dosbox-0.73.conf [If you scroll through it, there is a part that states the following:]

# xms: Enable XMS support.
# ems: Enable EMS support.
# umb: Enable UMB support.
# keyboardlayout: Language code of the keyboard layout (or none).



You could try to set the keyboard layout option manually, see DOS below,
or toggle EMS memory if it is not enabled.


Quoted From on February 8, 2010

default "auto" (since 0.73. Previously "none"), see KEYB for supported values (keyboard layout codes/ids)"

Needs Windows??

The game I want to play (Castle of the Winds) wsa designed for 16-bit processors, and I'm on Windows 7, which no longer supports that. But when I try to run it in DOSBox, it says "This program requires Microsoft Windows." What's that supposed to mean?

Are you sure you are atempting to run the proper DOSbox executable? Also, did you try running it in the backwards compatibility mode (ie. Windows XP or 98)? 06:58, 18 March 2010 (UTC)

It means what it says on the can. Castle of the Winds is a Windows game. You should be abler to run it if you set up a copy of Windows 3 in your DOSBox. -> -- 16:58, 27 March 2010 (UTC)

Dosbox/linux Cdrom not read

Hi. I am trying to run "Flight Unlimited" from cdrom. Drive D: is mounted as /dev/cdrom and I can change to the D: drive in Dosbox but a "dir" command gives file *.* not found. What am I doing wrong. Mount command used is "mount d /dev/cdrom -t cdrom -usecd 0 -ioctl" I have now made an iso of the cdrom and that seems to mount ok but when I try to run the game it fails with a message that it needs 524288 more bytes of disk space.Any Ideas?

Mouse tracking issues in Dosbox 0.74 - Windows 7 XP mode

Can anyone help, the mouse pointers are not tracking across the screen, instead they are going around the window borders in either window or full screen modes.