Software:QandA

From DOSBoxWiki
Jump to: navigation, search

Q&A is an old flat-file database program that was sold by Symantec for many years until it was discontinued in the mid-1990s. The latest DOS version I (Beerslayer) know of was version 5.0, but there were also versions for Windows (3.x?) that should probably not be expected to work in DOSBox.

Be aware that DOS versions of Q&A are not Year 2000 (Y2K) compliant unless a patch (readily available online) is applied. This has nothing to do with DOSBox, but is worth being aware of anyway.

Q&A versions 3.0 and earlier

I have never tried using any of these versions under DOSBox. I cannot comment on them, although my guess would be that they would work fine.

Q&A version 4.0

I have been using Q&A 4.0 under DOSBox for years. It seems to run flawlessly under DOSBox 0.72, 0.73, and 0.74. I have a fairly critical database that I have been updating with this combination, and I've never had a problem with it.

Q&A version 5.0

I have never personally used version 5.0. I understand that it had some compatibility issues with earlier versions of Q&A (databases were corrupted when converted from 4.0 to 5.0), but this has nothing to do with DOSBox.

Q&A for Windows

I have no information. I've never even seen this program, although I know it exists.